ID #1069

The NAT-service is unstable ... a workaround

Workstation and VMplayer install a NAT-service on the host which then operates on vmnet 8.
This service has a long history of problems.

On Windows 7 hosts - especially using the 64 bit varaiant many users complain that the service is unstable.

If you get this problems too you may want to use something more reliable.

In my experience the most stable NAT-service can be acchieved by using a VM instead of the buildin NAT-service.



Suggestion: use a m0n0wall VM instead - it runs happily with 64 MB of virtual RAM and can be configured with much more features than the build in services. AND it is rockstable.

Configuration of VMware-network:
launch VMware Network Editor
select vmnet0 : assign the network card that has access to the internet
select vmnet1 : set this to "hostonly" and uncheck "Use local DHCP to ..."
select vmnet8 : set this to "hostonly" and uncheck "Use local DHCP to ..."

Configuration of the VM:
assign 3 nics: vmnet0, vmnet1 and vmnet8
launch m0n0wall the first time: the firewall will detect nic0 , nic1 and nic2
first it asks for LAN-interface : assign nic1
then it asks for WAN-interface : assign nic0
last it asks for Optional 1 interface : assign nic2
now m0n0wall wants to reboot - allow this
after the reboot assign an IP for the admin-interface - this must be one from the same subnet
as used by the host for the vmnet1 virtual adapter.
finally create / reset the password for the WebGUI
now you can do the rest of the configuration via the WebGUI


m0n0wall homepage : http://m0n0.ch/wall/


Tags: monowall, nat, unstable

Related entries:

You can comment this FAQ